Generator question

Generator question

Postby Redetotry » Mon Nov 20, 2017 10:47 am

I wanted to run my generator before putting RV in storage but it would start then stop. After 3 tries it seem to be ok so I turned on the heat and it stopped. Should there be a wait period before you start any type of load?
Image
Redetotry
BJ
User avatar
Redetotry
 
Posts: 3781
Joined: Tue Jul 15, 2008 7:36 am
Location: Illinois

Re: Generator question

Postby Bethers » Mon Nov 20, 2017 4:50 pm

I usually wait about a minute... It doesn't get everything started immediately. So I make sure everything else is on first. You'll notice the fridge and microwave don't usually come up at the exact same time... Same idea.
Beth
On the Road with Beth
“Dare to live the life you have dreamed for yourself. Go forward and make your dreams come true.” ~ Ralph Waldo Emerson ~
"He who treasures the small things in life has found the path to true happiness" - ?
User avatar
Bethers
 
Posts: 13390
Joined: Sat Jul 12, 2008 9:00 pm
Location: Currently SD for the summer and fall

Re: Generator question

Postby Redetotry » Thu Nov 23, 2017 9:24 am

Bethers wrote:I usually wait about a minute... It doesn't get everything started immediately. So I make sure everything else is on first. You'll notice the fridge and microwave don't usually come up at the exact same time... Same idea.


Thanks Beth.
Image
Redetotry
BJ
User avatar
Redetotry
 
Posts: 3781
Joined: Tue Jul 15, 2008 7:36 am
Location: Illinois


Return to Maintenance/Tech Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron